using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a{0,3}";
string input = @"gaaaaf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}