$re = '/(?<!\S)(?:[0-9]{1,2}[,.\'][0-9]{3}|\d{3,})(?!\S)/m';
$str = 'some text 12.444 12,444 12\'444 123.122 12.1234 12345 1234 12.12 12.1234567 12.242Text 12.242 Text Text12.242 Text12.242Text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);