$re = '/(?:(?!ad)..|^.)v\|/m';
$str = 'coord|and adv|then pro|it mod|may v|hurt det|the n|dog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);