$re = '/(\d*?\.\d{2})/';
$str = '35000.0000 to 35000.0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);