# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"sort_id\"([\w\W\-_*+.,]+)\"sort_id\""
test_str = ("\"11428\": {\n"
" \"item_id\": \"11428\",\n"
" \"resolved_id\": \"11428\",\n"
" \"given_url\": \"http://www.perpetualkid.com/\",\n"
" \"given_title\": \"Perpetual Kid - Unique Gifts to Entertain Your Inner Child\",\n"
" \"favorite\": \"0\",\n"
" \"status\": \"0\",\n"
" \"time_added\": \"1504308897\",\n"
" \"time_updated\": \"1523244253\",\n"
" \"time_read\": \"0\",\n"
" \"time_favorited\": \"0\",\n"
" \"sort_id\": 1185,\n"
" \"resolved_title\": \"Fun + Unique gifts for the young at heart! Unusual + affordable gift ideas for guys, girls, mom, dad, kids, and pets!\",\n"
" \"resolved_url\": \"https://www.perpetualkid.com/\",\n"
" \"excerpt\": \"At Perpetual Kid, we’ve been dedicated to finding the most fun and unique gifts for over 10 years! Browse our unusual selection of fun and uncommon gifts and gadgets for your own amusement, or to find a lucky gift recipient the perfect present.\",\n"
" \"is_article\": \"0\",\n"
" \"is_index\": \"1\",\n"
" \"has_video\": \"0\",\n"
" \"has_image\": \"0\",\n"
" \"word_count\": \"137\",\n"
" \"lang\": \"en\"\n"
" },\n"
" \"13488\": {\n"
" \"item_id\": \"13488\",\n"
" \"resolved_id\": \"13488\",\n"
" \"given_url\": \"http://www.overheardinnewyork.com/\",\n"
" \"given_title\": \"Overheard in New York | The Voice of the City\",\n"
" \"favorite\": \"0\",\n"
" \"status\": \"0\",\n"
" \"time_added\": \"1504308901\",\n"
" \"time_updated\": \"1523244252\",\n"
" \"time_read\": \"0\",\n"
" \"time_favorited\": \"0\",\n"
" \"sort_id\": 1090,\n"
" \"resolved_title\": \"Overheard In New York\",\n"
" \"resolved_url\": \"http://www.overheardinnewyork.com/\",\n"
" \"excerpt\": \"Woman in leggings: What the fuck is this shit? You gonna hand me three motherfucking sugar packets? Do you have any idea how big this coffee is? Cashier: We don’t put sugar in your coffee. Sugar packets are on the counter. Woman in leggings: Listen, my boyfriend’s a cop.\",\n"
" \"is_article\": \"0\",\n"
" \"is_index\": \"1\",\n"
" \"has_video\": \"0\",\n"
" \"has_image\": \"1\",\n"
" \"word_count\": \"642\",\n"
" \"lang\": \"\"\n"
" },")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.