import re
regex = re.compile(r"^(?:(https?):)?(\/\/.*\.[^\/]+)$", flags=re.MULTILINE)
test_str = ("Regex for http:/https: or only domain url stating with a slash\n\n"
"Examples:\n"
"https://example.domain\n"
"http://example.domain\n"
"//example.domain\n"
"//example.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")