import re
regex = re.compile(r"-\s?\d{4}[\s*]*\w*\s?\w*")
test_str = "\\Diageo_Catalogues\\CATALOGUES_SEPTEMBER_2015\\test for WE\\Haig Club - 2015 Global eu"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")