re = /^[a-z0-9._%+-]{1,40}[@]{1}[a-z]{1,20}[.]{1}[a-z]{2,8}$/m
str = 'dhdhdh@xxx.essadsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end