$re = '/(^\d{4}\d$|^\d{4}\d-\d{4}$)/m';
$str = '12345
12345-1234
123-456
-544658
12345a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);