using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"BLA(?:(?!BLA).)*?LOOK";
string input = @"BLA text text text text text text BLA text text text text LOOK text text text BLA text text BLA";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}