const regex = /[a-z]{2}-[A-Z]{2}(?=:1)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-z]{2}-[A-Z]{2}(?=:1)', 'g')
const str = `\\r\\nab-CD:2\\r\\nab-EF:1\\r\\nbc-DE:3\\r\\ndz-LF:1\\r\\nkr-TZ:2\\r\\nef-DD:1\\r\\nlv-ER:2\\r\\ndf-QW:3\\r`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}