$re = '/"[^"]*"$/m';
$str = 'haha "h1" "hi"
haha "h1" "hi hi"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);