$re = '/\[cmd:(.+?)\]/m';
$str = 'foo [cmd:tag1] bar [cmd:tag2] bla bla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);