package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-z0-9][A-z0-9\-]*[A-z0-9]$`)
var str = `en
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}