$re = '/(?<=than\s)better(?=\sabsolutely)/';
$str = 'Imperfection is beauty, madness is genius and it’s than better to be absolutely ridiculous than better absolutely boring';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);