const regex = /(?=\/[A-Z])\/[A-Z].+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\\/[A-Z])\\\/[A-Z].+$', 'gm')
const str = `aa/xx/Ab/Cd
bb/yy/zz/Ef
aa/aa/aa/AA
bb/bb/BB/AA
df/sd/sfA/Rg
aa/xx/Abc/Def <- fail`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}