$re = '/\s(\d+)[ \/](\d+)(\s|$)/';
$str = 'rspec 0 20
rspec 3 20
rspec 4/40
rspec 5/20 ruby21';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);