using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^(?:- )*-) ";
string substitution = @"";
string input = @"- - - Three dashes a-b-c-d
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}