const regex = new RegExp('^(.*?)(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?(?:,(.+?))?$', 'gmi')
const str = `1.jpg,2.jpg,3.jpg,4.jpg,5.jpg,6.jpg,7.jpg,8.jpg,9.jpg,10.jpg,11.jpg,12.jpg,13.jpg,14.jpg,15.jpg,16.jpg,17.jpg,18.jpg,19.jpg,20.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}