# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(.*?)(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?(?:;(.+?))?$
"""
test_str = "1.jpg;2.jpg;3.jpg;4.jpg;5.jpg;6.jpg;7.jpg;8.jpg;9.jpg;10.jpg;11.jpg;12.jpg;13.jpg;14.jpg;15.jpg;16.jpg;17.jpg;18.jpg;19.jpg;20.jpg"
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.