$re = '/^(.*?)(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?(?:\|(.+?))?$/mix';
$str = '1.jpg|2.jpg|3.jpg|4.jpg|5.jpg|6.jpg|7.jpg|8.jpg|9.jpg|10.jpg|11.jpg|12.jpg|13.jpg|14.jpg|15.jpg|16.jpg|17.jpg|18.jpg|19.jpg|20.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);