#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^.*access-list([^\s]*\s){1}(?<src_acl>[^\s]+)\s([^\s]*\s){2}(?<src_iface>[a-z]+)\/(?<src_ip>[0-9.]+)\((?<src_port>[0-9]+)\)\s->\s(?<dest_iface>[a-z]+)\/(?<dest_ip>[0-9.]+)\((?<dest_port>[0-9]+)"
Local $sString = "Aug 28 16:02:42 dmzfw-cal.mgmt.biz.lodh.com Aug 28 2015 16:02:42: %ASA-4-106100: access-list acl_dmzout permitted tcp dmzout/192.168.200.20(46301) -> outside/74.120.148.12(80) hit-cnt 1 first hit [0x35de8ee6, 0x0]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")