$re = '/^.*_F\d+_C\d+$/';
$str = 'Some_text_here_F12_C12';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);