$re = '/(\w|\s|^)(бан|ban)(\w|\s|$)/i';
$str = 'Бан1234
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);