$re = '/(?<="0":).*?(?=,)/im';
$str = '1":7.18,"2":20.69,"0":1.09,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);