package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(water-ing|water)\b`)
var str = `water water-ing`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}