import re
regex = re.compile(r"\$\$(?:[^$][^$])*\$\$", flags=re.MULTILINE | re.DOTALL)
test_str = ("Lorem ipsum dolor sit ame $ a = \\{ b, c \\} $ Lorem 100 \\$ ipsum\n"
" $$ \\left \\{ \n"
" \\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\\\y_2 =&2 x_2\\\\y_3 =&x_1 - x_2 + 3 x_3\\end{array} \n"
" \\right.\n"
" \\Leftrightarrow \\left \\{ \n"
" \\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\\\8 x_2 =&4 y_2\\\\8 x_3 =&-y_1 + y_2 + 3 y_3\\end{array} \n"
" \\right.\n"
" $$ Lorem ipsum dolor\n"
" $$ \\left \\{ \n"
" \\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\\\y_2 =&2 x_2\\\\y_3 =&x_1 - x_2 + 3 x_3\\end{array} \n"
" \\right.\n"
" \\Leftrightarrow \\left \\{ \n"
" \\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\\\8 x_2 =&4 y_2\\\\8 x_3 =&-y_1 + y_2 + 3 y_3\\end{array} \n"
" \\right.\n"
" $$ Lorem ipsum dolor ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")