# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\(?([\w']+)(?: *\/ *| +or +)([\w']+)\)?"
test_str = ("someone can tell/figure\n"
"a/the squeaky wheel gets the grease/oil\n"
"accounts for (someone or something)\n"
"that's/there's (something/someone) for you\n\n"
"_OUTPUT_\n"
"someone can tell\n"
"someone can figure\n"
"a squeaky wheel gets the grease\n"
"a squeaky wheel gets the oil\n"
"the squeaky wheel gets the grease\n"
"the squeaky wheel gets the oil\n"
"accounts for someone\n"
"accounts for something\n"
"that's something for you\n"
"that's someone for you\n"
"there's something for you\n"
"there's someone for you")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.