$re = '/^[\+\-]?\$?(\d+|\d{1,3}(,\d{3})*)(\.[0-9]+)?$/';
$str = '$2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);