package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([:?]\s*\[\w+(?:\s*,\s*)?\w+\])`)
var str = `: [J, BASIC]
? [CINTERMEDIATE]
: [D,MEDIUM]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}