re = /([A-Za-z-éèë]+) (\b[A-Z][A-ZÉ\s]+\b)/m
str = 'Marie-Noelle CHRAITI, Delphine PERRÉARD, Americo AGOSTINHO, Isabelle SOULAKE, Marlène FRACCARO HAMONEAU, Véronique CAMUS, Monique PEREZ, Henrique ALVES, Valérie SAUVAN, Claude GINET'
subst = '$2 $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result