package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/(\d{1,3})\b`)
var str = `/news/2016/2
/news/2/2016`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}