package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b'\b`)
var str = `Foo 'can't' bar 'don't'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}