$re = '/^(%{2})(.*(?!\1).*)\1$/m';
$str = '%%askdj%%kl%%
%%askdj%kasd% lasdkl%%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);