re = /[01]*11[01]*/
str = '0100110, 0111, 00010011001, 010101010101, 0000000, 00100000001'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end