$re = '/(?<=-)[0-9]{4,}(?=")/';
$str = '<a href="http://digitalocean.com/info/hello-23-kitty-show-1-d-zay-ya-9013294119" title="Hello Kitty (Show & Zay Ya" style="font-size:medium;" target="_blank" class="highlight-item">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);