import Foundation
let pattern = #"\b(?!\w\s{1,2}\w+)\w(\w|\s){3}\d{10}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
a regular expression using C#/.Net that matches 1-4 alphanumerics followed by spaces, followed by 10 digits.
The catch is the number of spaces plus the number of alphanumerics must equal 4,
and the spaces must follow the alphanumerics, not be interspers
abcd1234567890 y
a 1234567890 y
ab 1234567890 y
1 1234567890 y
1 1234567890 n
1 1234567890 n
11234567890 n
a c 1234567890 n
a d1234567890 n
abcd 1234567890 n
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)