$re = '/\d+(?:\.\d+)?/';
$str = 'var string="0px 0px 4.5px";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);