const regex = /([a-zA-Z]+)\s([a-zA-Z]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]+)\\s([a-zA-Z]+)', 'g')
const str = `
1 Agra Achhnera NIL
2 Agra Agra NIL
3 Agra Fatehabad NIL
4 Agra Fatehpur Sikri NIL
5 Agra Jagner NIL
6 Agra Jarar NIL
7 Agra Khairagarh NIL
8 Agra Shamshabad NIL
9 Aligarh Atrauli NIL
10 Aligarh Chharra NIL
11 Aligarh Aligarh 1300.00
12 Aligarh Khair 1300.00
13 Allahabad Allahabad NIL`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);