$re = '~^(?!.*?(\w)\1{5}).*$~m';
$str = 'ab111111
ab:D1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);