package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:{(?:[a-zA-Z]:)?[a-zA-Z_]\w*}){2,}(*SKIP)(*F)|{(?:(?<type>[a-zA-Z]):)?(?<name>[a-zA-Z_]\w*)}`)
var str = `/home/{i:id}{s:noVar}/{m:varName}/{s:someOther}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}