package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#
# Inspired by http://stackoverflow.com/questions/6556559/youtube-api-extract-video-id
# Example: https://www.youtube.com/watch?v=o8QuLYXKNCg&rel=0&autoplay=1
#
# Match any youtube URL
(?:https?://)? # Optional scheme. Either http or https
(?:www\.)? # Optional www subdomain
(?: # Group host alternatives
youtu\.be/ # Either youtu.be,
| youtube\.com # or youtube.com
(?: # Group path alternatives
/embed/ # Either /embed/
| /v/ # or /v/
| /watch\?v= # or /watch\?v=
) # End path alternatives.
)? # End host alternatives.
([\w-]{10,12}) # Allow 10-12 for 11 char youtube id.
(?:[&?](.*)) # Optional Parameters
$`)
var str = `https://www.youtube.com/watch?v=o8QuLYXKNCg&rel=0&autoplay=1&autoplay=2&autoplay=3&autoplay=4`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}