import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!<(script|code)[^>]*?>)((\\s)(\\?|\\!|\\;|\\:))(?![^<]*?<\\/(script|code)>)";
final String string = "<h2>Déroulement de votre examen radiologique ?</h2>\n"
+ "<p>test De l’accueil dans nos locaux à la remise des résultats, toute l’équipe Radiolor, médecins radiologues, manipulateurs et secrétaires, reste à votre service et met tout en œuvre pour que votre temps d’attente soit 66 limité et que votre examen se déroule dans les meilleures conditions. Tous les gestes médicaux sont <a>réalisés dans les conditions d’hygiène strictes ; et : dans </a>le respect des bonnes pratiques.</p>\n"
+ "<p>À votre arrivée , nous vous remercions de passer par le secrétariat et de vous munir de votre ordonnance et de votre carte vitale !.<br />\n"
+ "N’oubliez pas vos anciens examens et <strong>respectez les consignes</strong> qui vous ont été transmises lors de votre prise de <code>rendez-vous : </code>prise de sang, éventuel produit de contraste ou d’infiltration prescrit ?.</p>\n"
+ "<!-- meta slider -->\n"
+ "test\n"
+ "</div>\n\n"
+ "<script type=\"text/javascript\">\n"
+ "var timer_metaslider_144 = function() {\n"
+ " var slider = ;!window.jQuery ? window.setTimeout(timer_metaslider_144, 100) : !jQuery.isReady ? window.setTimeout(timer_metaslider_144, 1) : metaslider_144(window.jQuery);\n"
+ " };\n"
+ " timer_metaslider_144();\n"
+ "</script>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}