import re
regex = re.compile(r"^0+\B", flags=re.MULTILINE)
test_str = ("005\n"
"0AB\n"
"000\n"
"0\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)