$re = '/,(?![^\(\[]*[\]\)])/';
$str = 'Harry Potter, [and, the chamber, of secrets], Hermione, (Olivanders, Wands)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);