$re = '/"(\d*),(\d+\$)"/';
$str = '"100,21$"';
$subst = "\"$1.$2\"";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;