package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(0[1-9]|1[0-9]|2[0-9]|3[01]).(0[1-9]|1[012]).([0-9]{4})( ([0-1]\d|2[0-3])(:[0-5]\d){2}|)`)
var str = `21.10.2013 13:27:35`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}