$re = '/^(?![a-z_]+)([+\-]?\d+(?:\.\d+)?)/m';
$str = 's1
s2
s4.3
1
2
1.2
-1.2
4.555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);