$re = '/(\d+)(\-)?/m';
$str = '140,13-,3-,40-,2-';
$subst = "\2\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;