package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)os ([0-9]+(?:_[0-9]+)*)`)
var str = `Mozilla/5.0 (iPhone; CPU iPhone OS 13 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Mobile/15E148
Mozilla/5.0 (iPhone; CPU iPhone OS 13_3 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Mobile/15E148
Mozilla/5.0 (iPhone; CPU iPhone OS 13_3_3 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Mobile/15E148`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}